Funkce když,excel

Od: Datum: 03.12.12 18:11 odpovědí: 7 změna: 03.12.12 19:42
avatar

Ahoj, poradíte mi prosím? Potřebuju určit pravdivostní hodnotu u několika buněk najednou- vzorec jsem zapsala =KDYŽ((B3:L3)>4;"neprospěl";"prospěl"), hlásí mi to chybu #HODNOTA! ani když si buňky označím zvlášť (B3;C3;...) tak mi to nefunguje, nevíte v čem by mohla být chyba? Děkuju za radu


avatar
Upozornění
Tato otázka je 4 roky bez odpovědi a proto byla uzavřena.
Máte-li podobnou otázku, a nenašli jste vhodnou odpověď, založte novou otázku.
Seznam odpovědí:
 
moment čekejte prosím, probíhá přenos dat...
Zobrazení struktury odpovědí v otázce
Skrytí struktury odpovědí v otázce
Zobrazení struktury odpovědí v otázce

 

Odpovědi na otázku:
Datum: 03.12.12 18:35
 
avatar

Takhle vám to nebude fungovat. Co chcete porovnat s číslem 4? Součet B3 až L3? Nebo průměr B3 až L3 musí být větší než 4? To by šlo.

Jestli chcete stejný počet výstupních jako vstupních hodnot, napište si tuto podmínku jen pro B3 a pak ji nakopírujte (tažením za spodní pravý roh) pro všechny ostatní. Takže tam budete mít 11x prospěl nebo neprospěl.

Jestli chcete jeden výsledek, prospěl pouze v případě, že prospěl ve všem, tak to udělejte podobně jako v předchozím případě a pak to uzavřete do funkce A(), použití viz nápověda k ní.

Ohodnoceno: 1x
 
Od: mowla*
Datum: 03.12.12 18:43
 

Mám dojem, že půjde spíše o zřetězení podmínek...

Klero - ujasni si, zda tu podmínku musí splnit všechny buňky a nebo alespoň jedna z nich... V každém případě musíš podmínku napsat pro každou buňku zvlášť a jednotlivé podmínky - podle potřeby - ´svázat´ buďto operátorem AND a nebo OR...

;)

 
Datum: 03.12.12 18:47
 
avatar

Aha...tak tohle zkusím, děkuju :)

Datum: 03.12.12 18:46
 
avatar

Já mám napsanou tabulku př. 1 2 1 3 4 3 (známky na vysvědčení) a pokud je jedna ze známek rovna 5 (větší 4) tak potřebuju vypsat "neprospěl" v opačném případě "prospěl", takže potřebuju jeden výsledek "prospěl", v případě, že podmíka není splněna, ale v opačném případě "neprospěl", dá se tohle řešit funkcí A()? Děkuju za odpověď

Datum: 03.12.12 19:17
 
avatar

to vypadá na složený IF.

Když A1>4 nebo A2>4 nebo A3>4 nebo A4>4 nebo A5>4, potom napsat neprospěl, jinak napsat prospěl.

=IF(OR(A1>4;A2>4;A3>4;A4>4;A5>4);"neprospel";"prospel")

 
Datum: 03.12.12 19:32
 
avatar

nebo:

=když(countif(A:A;5)>0;"neprospěl";"prospěl")

aneb když ve sloupečku bude nějaká pětka, neprospěl.

Ohodnoceno: 2x
 
Datum: 03.12.12 19:42
 
avatar

Jo, to je ono...takhle přesně jsme to řešili ve škole...děkuju moc :)

 

 

 

Neneseme odpovědnost za správnost informací a za škodu vzniklou jejich využitím. Jednotlivé odpovědi vyjadřují názory jejich autorů a nemusí se shodovat s názorem provozovatele poradny Poradte.cz

 
Copyright © 2004-2016 Poradna Poradte.cz. Všechna práva na poradně Poradte.cz vyhrazena.