Excel -

Od: Datum: 05.12.15 21:49 odpovědí: 5 změna: 06.12.15 12:33

dobrý den, potřeboval bych poradit s jedním "příkladem" do Excelu ..

ve sloupci A mám zadené hodnoty, ve sloupci C musím přičíst hodnotu ze stejného řádku ze slouce A k hodnotě z nejbližšího vyžšího řádku ze sloupce C (v C50 je C49 + A50, C51 je C50 + A51 atd ... problém nastává když C56 je C53 + A56 .. o tři řádky výš) .. hodnotu ve sloupci A múžou být libovolně poskládané (libovolně dlouhé mezery) múže tam být cca 500 hodnot a budou se měnit takže je nesmysl dělat každej řádek zvlášť .. chtělo by to nějakej univerzální vzorec

pokud někdo výte jak na to tak předem děkuju za radu



Seznam odpovědí:
 
moment čekejte prosím, probíhá přenos dat...
Zobrazení struktury odpovědí v otázce
Skrytí struktury odpovědí v otázce
Zobrazení struktury odpovědí v otázce

 

Odpovědi na otázku:
Datum: 06.12.15 09:18
avatar

Problém nenastává na řádku 56, protože 195 +65 je 260, ale nechápu hodnotu 270 na řádku 57.


doplněno 06.12.15 10:25:

myslím, že to jde i jednoduchým vzorcem, jen stále nechápu hodnotu 270, podle mě tam má být 335 protože A57(75) plus hodnota z nejbližšího vyššího řádku sloupce C, tedy z C56 = 260. 260 + 75 = 335.

Ohodnoceno: 0x
 
Od: jahodak
Datum: 06.12.15 12:00

máte pravdu .. přičetl jsem to zase k C53 (195+75=270)

Datum: 06.12.15 09:47

Na tohle není vzorec. Na to musí být relativně jednoduché makro (program) ve Visual Basicu.

Ohodnoceno: 0x
 
Datum: 06.12.15 10:36

To makro lze snadno udělat jako vlastní funkci. Pokud by to bylo potřeba, pak by se mělo stanovit, jestli i řádky v C mají zůstat prázdné. Pokud ne, pak stačí jednoduché sčítání. Pokud ano, šlo by to nejjednodušeji tak, že by byl sloupec B skrytý a v něm jednoduché sčítání a hodnota z B do C by se přenášela jen v případě, že buňka ve sloupci A není prázbná.


doplněno 06.12.15 10:51:

Ještě by přicházela v úvahu tato možnost: Dejme tomu, že tabulka ve sloupci A zažíná - 1. položka - v buňce A10. Poak ve sloupci C bude vztah, počínaje buňkou C11:

=Když(A11 = ""; "";Suma($A$10;$A11)

Ohodnoceno: 2x
 
Datum: 06.12.15 12:33
avatar

Jde to samozřejmě bez makra (funkce) a i bez pomocných či skrytých sloupců.

Do C5 napiště tento vzorec a zkopírujte dolů.

=KDYŽ((A50+SUMA($A$1:A49))=SUMA($A$1:A49);"";A50+SUMA($A$1:A49))


doplněno 06.12.15 17:02:

samozřejmě C50 a ne C5

Ohodnoceno: 0x
 

 

 

Přihlásit se k odběru odpovědí z této otázky:

Neneseme odpovědnost za správnost informací a za škodu vzniklou jejich využitím. Jednotlivé odpovědi vyjadřují názory jejich autorů a nemusí se shodovat s názorem provozovatele poradny Poradte.cz

 
Copyright © 2004-2016 Poradna Poradte.cz. Všechna práva na poradně Poradte.cz vyhrazena.