Excel - SUMA absolutních hodnot

Od: Datum: 16.11.15 12:37 odpovědí: 3 změna: 17.11.15 09:01

dobrý den potřeboval bych poradit jak hromadně sčítat absolutní hodnoty čísel ..

ve sloupci A:A mám vypsaná čísla -400 až +400 a potřebuju zjistit jejich součet bez ohledu na znaménka

(tj. -350 +300 +120 -50 ... = 820)


Seznam odpovědí:
 
moment čekejte prosím, probíhá přenos dat...
Zobrazení struktury odpovědí v otázce
Skrytí struktury odpovědí v otázce
Zobrazení struktury odpovědí v otázce

 

Odpovědi na otázku:
Datum: 16.11.15 13:34

zkusil bych napsat vzoreček =suma(abs(A1:A7)) a při ukládání stisknout Ctrl+Shift+Enter, aby se to uložilo jako maticový vzorec. (Pokud jsou ta čísla v buňkách A1 až A7, jinak změnit odkaz na tu oblast, kterou chci sčítat).

Ohodnoceno: 0x
 
Datum: 16.11.15 13:48

Poněkud humpolácky to lze takto: =SUMIF(A1:A3;">0")+ABS(SUMIF(A1:A3;"<0"))

(Pro oblast A1:A3)

Pokud předpokládám, že požadavek je nerozepisovat do více sloupců. Převést číslo nejprve na absolutní hodnotu a ty pak sečíst zvládne asi každý.

Ohodnoceno: 0x
 
Datum: 17.11.15 09:01
avatar

maticový vzorec:

=SUMA(ABS(A:A)), pokud jsou čísla ve sloupci A

Ohodnoceno: 0x
 

 

 

Přihlásit se k odběru odpovědí z této otázky:

Neneseme odpovědnost za správnost informací a za škodu vzniklou jejich využitím. Jednotlivé odpovědi vyjadřují názory jejich autorů a nemusí se shodovat s názorem provozovatele poradny Poradte.cz

 
Copyright © 2004-2016 Poradna Poradte.cz. Všechna práva na poradně Poradte.cz vyhrazena.