Excel a počet datumů v tomto měsíci

Od: Datum: 14.08.15 11:23 odpovědí: 10 změna: 23.08.15 19:19
avatar

Zdravím, potřebuji ještě jednu radu k Excelu.

Ve sloupci mám několik datumů, různě od ledna až do prosince.

Potřebuji vzorec jak z nějakého slouce dostanu počet kolik je datumu v tomto měsíci v tom určitém sloupci.

Umím počet určitého dne, umím počet dřív než nějaký datum, ale neumím rozmezí dat, nebo lépe toho určitého měsíce

Předem děkuji

vyzkopušel jsem kdejakou radu na netu, ale nenašel jsem..


Seznam odpovědí:
 
moment čekejte prosím, probíhá přenos dat...
Zobrazení struktury odpovědí v otázce
Skrytí struktury odpovědí v otázce
Zobrazení struktury odpovědí v otázce

 

Odpovědi na otázku:
Datum: 14.08.15 12:03
avatar

V jakém tvaru máte ten datum.

Ohodnoceno: 0x
 
Datum: 14.08.15 13:29
avatar

zobrazuje se jako 2.3.2015 zadávám ho jako 2-3-2015

předem děkuji

Datum: 14.08.15 22:17
avatar

Z hlavy nic neporadím, zkusím si s tím pohrát. Předpokládám, že nejdříve bude důležité upravit datumy do stejného formátu a stejné délky např. ( 02.03.2015 , 14.11.2015). S tím už by se mělo dát třeba pomocí řetězců a jejich částí něco dělat. Zatím to budu zkoušet.

Ohodnoceno: 0x
 
Od: monkey
Datum: 14.08.15 23:15

Pokud jsem to správně pochopil, tak tu je příklad:

Sloupec A: datumy
Buňka B1: rok
Buňka C1: měsíc
Buňka D1: =COUNT(A:A)-COUNTIF(A:A;"<"&DATE(B1;C1;1))-COUNTIF(A:A;">"&DATE(B1;C1+1;0))

Ohodnoceno: 2x
 
Datum: 16.08.15 17:48
avatar

Nejprve jsem myslel, že jsme se nepochopili, ale až jsem si to v klidu přečetl, tak to vypadá ( pokud je to funkční) že by to mohlo být OK, otestuji zítra přímo v tabulce, zatím díky

Oběma za snahu

doplněno 16.08.15 18:14:

Testuji to a někde je zadrhel

v Scr posílam detail nastavení datumu a detail vložené funkce, něco není OK, možná to jen špatně chápu?

doplněno 16.08.15 18:15:

obrazek nešel 3x odeslat v IE -->> hruza

odesílat to v Chrome .. je mi z toho AUVA

Od: monkey
Datum: 16.08.15 18:39

Asi to bude tím, že používám anglické názvy funkcí. Funkční je to určitě.

Buňka D1: =POČET(A:A)-COUNTIF(A:A;"<"&DATUM(B1;C1;1))-COUNTIF(A:A;">"&DATUM(B1;C1+1;0))

Ohodnoceno: 2x
 
Datum: 16.08.15 20:44
avatar

To jsem blázen?

Změnil jste něco nebo jen češtinu?

Já vždy používám anglické názvy

Ale s češtinou to funguje.. jak je to možné?

Od: monkey
Datum: 16.08.15 22:51

1. To já nedokážu posoudit. *smich*

2. Jen češtinu: COUNT <-> POČET a DATE <-> DATUM

Mám záměrně změněný jazyk funkcí v Excel 2003 na anglický, takže mě zase nefungují české názvy. Opravdu Vám funguje např. "=COUNT(A:A)" i "=POČET(A:A)"?

Ohodnoceno: 0x
 
Datum: 23.08.15 19:09
avatar

Zdravím, chvíli jsem tu nebyl.

COUNTIF používám běžně .. ale zmílil jsem se, opravdu česka verze chce slovo DATUM a DATE mi nebere .. to jsem z toho jelen. Hlavně ALE Vaše rada mi moc pomohla. Body jsem udělil a ještě jednou moc děkuji

p.s. "=COUNT(A:A)" i "=POČET(A:A)"? tedy nejde ani u mne

doplněno 23.08.15 19:26:

Bez uvozovek, tedy jen:

=COUNT(A:A)

a

=POČET(A:A)

p.s.: jasny jasny

Od: monkey
Datum: 23.08.15 19:19

Bez uvozovek, tedy jen:

=COUNT(A:A)

a

=POČET(A:A)

Ohodnoceno: 0x
 

 

 

 

 

Přihlásit se k odběru odpovědí z této otázky:

Neneseme odpovědnost za správnost informací a za škodu vzniklou jejich využitím. Jednotlivé odpovědi vyjadřují názory jejich autorů a nemusí se shodovat s názorem provozovatele poradny Poradte.cz

 
Copyright © 2004-2016 Poradna Poradte.cz. Všechna práva na poradně Poradte.cz vyhrazena.