Skrytí chybové hlášky funkce v Excelu

Od: Datum: 13.03.15 01:10 odpovědí: 5 změna: 30.03.15 05:16
avatar

Používám ke všeobecné spokojenosti vzoreček.

=SVYHLEDAT(D18;SEZNAM!$A$2:$B$65419;2;NEPRAVDA)

který mi zobrazuje buď hodnotu kterou najde na listu SEZNAM v určených sloupcích a pokud ji nenajde, vyhodí hlášku

#NENÍ_K_DISPOZICI

Šlo by nějak tuto hlášku skrýt tak aby buňka byla jakoby prázdná? Pokud ne, tak alespoň vypsat třeba "x".


Seznam odpovědí:
 
moment čekejte prosím, probíhá přenos dat...
Zobrazení struktury odpovědí v otázce
Skrytí struktury odpovědí v otázce
Zobrazení struktury odpovědí v otázce

 

Odpovědi na otázku:
Datum: 13.03.15 08:15

Zkusim bych v tom vzorci nahradit ono "nepravda" prázdným řetězcem "".

Ohodnoceno: 0x
 
Datum: 30.03.15 05:14
avatar

Místo #NENÍ_K_DISPOZICI to napíše #HODNOTA!

Od:
Datum: 13.03.15 10:31

Použijte funkci IFERROR:

=IFERROR(SVYHLEDAT(D18;SEZNAM!$A$2:$B$65419;2;NEPRAVDA);"") ...buňka bude při chybě prázdná

=IFERROR(SVYHLEDAT(D18;SEZNAM!$A$2:$B$65419;2;NEPRAVDA);"X") ...buňka bude při chybě obsahovat "X"

Ohodnoceno: 1x
 
Datum: 14.03.15 11:06
avatar

Děkuji, v pondělí v práci vyzkouším. *palec*

Datum: 30.03.15 05:16
avatar

Místo #NENÍ_K_DISPOZICI to napíše #NÁZEV? v obou případech.

 

 

Přihlásit se k odběru odpovědí z této otázky:

Neneseme odpovědnost za správnost informací a za škodu vzniklou jejich využitím. Jednotlivé odpovědi vyjadřují názory jejich autorů a nemusí se shodovat s názorem provozovatele poradny Poradte.cz

 
Copyright © 2004-2016 Poradna Poradte.cz. Všechna práva na poradně Poradte.cz vyhrazena.