Excel 2010 podmíněné formátování

Od: Datum: 22.02.15 16:48 odpovědí: 3 změna: 23.02.15 09:47
avatar

V Excelu 2010 mám dvě buňky s různými datumy. Ve třetí buňce mám vzorec který spočítá rozdíl mezi daty spolu s podmínkami a podle výsledku se buňka podbarví určenou barvou definovanou podmíněným formátováním.

Podmínky jsou takové - novější datum - 15 dní = zbytek a ten poslouží k podmíněnému formátování:

- pokud zbude 20 dní a více, musí se zobrazit vždy hodnota 20 a buňka se podbarví zeleně

- pokud zbyde 1 - 19 dní, musí se zobrazit skutečný výsledek a buňka se podbarví žlutě

- pokud zbyde 0 dní a méně (mínusová hodnota), musí se vždy zobrazit 0 a buňka se podbarví červeně

Zde je vzorec třetí buňky: =IF(B5-15>20;"20";IF(B5-15<1;"0";B5-15))

Všechno funguje, akorát při hodnotě nula a menší (mínusové) se buňka nechce podbarvit červeně a podbarvuje se zeleně. Netuším kde je chyba.



Seznam odpovědí:
 
moment čekejte prosím, probíhá přenos dat...
Zobrazení struktury odpovědí v otázce
Skrytí struktury odpovědí v otázce
Zobrazení struktury odpovědí v otázce

 

Odpovědi na otázku:
Datum: 22.02.15 19:18
avatar

Pokud chcete, aby vám vzorec vracel číslo a ne číslo v textovém tvaru, tak ho nedávejte do uvozovek.

Správně by mělo tedy být: =IF(B5-15>20;20;IF(B5-15<1;0;B5-15))

Ohodnoceno: 2x
 
Datum: 22.02.15 19:44

Vzorecek obsahuje chybu ve formatu

Odstranit uvozovky u hodnot ve vzorci. navic jsem odstranil vzorce v podminkach a odkazal se na sloupec D2 s rozdilem B2-15

Spravne je vzorec =KDYŽ(D2>20;20;KDYŽ(D2<1;0;D2))

Ohodnoceno: 2x
 
Od: ds23®
Datum: 23.02.15 09:47
avatar

Děkuji všem, funguje to. ;)

 

 

Přihlásit se k odběru odpovědí z této otázky:

Neneseme odpovědnost za správnost informací a za škodu vzniklou jejich využitím. Jednotlivé odpovědi vyjadřují názory jejich autorů a nemusí se shodovat s názorem provozovatele poradny Poradte.cz

 
Copyright © 2004-2016 Poradna Poradte.cz. Všechna práva na poradně Poradte.cz vyhrazena.