Vlastní web - nezobrazuje se pozadí

Od: Datum: 15.03.13 09:50 odpovědí: 25 změna: 15.03.13 23:27

Zdravím,

mám vlastní webové stránky a i když je vše funkční a jede tak, jak má, nejede mi pozadí.

Obrázek vložený jako "plocha"/podklad/pozadí stránek prostě nefunguje.
Vše nahrávám přes ftp, náhráno je v pořádku, ale nezobrazuje se.
Nevíte někdo, čím to může být?
Co třeba formát? Mám to v jpg.

Díky.


Seznam odpovědí:
 
moment čekejte prosím, probíhá přenos dat...
Zobrazení struktury odpovědí v otázce
Skrytí struktury odpovědí v otázce
Zobrazení struktury odpovědí v otázce

 

Odpovědi na otázku:
Od: 111®
Datum: 15.03.13 10:06

jpg. nevadí...akorát vadí třeba obrázek .jpg a odkaz na něj JPG. to nefunguje...nebo opačně...

Ohodnoceno: 0x
 
Od: dery®
Datum: 15.03.13 10:19

Tomu moc nerozumím.
Pokud mám obrázek uložený na vytvořené stránce jako pozadí, stránku i obrázek mám přes ftp hozené na internet, jaký odkaz může nefungovat?

Od: 111®
Datum: 15.03.13 10:25

obrázek je .jpg, apak by jsi tam měl mítnějaký soubor.htm a vněm je definováno to pozadí , tedy odkaz na ten obrázek...co natom není jasný? dej sem adresu toho webu..se kouknu...

Ohodnoceno: 0x
 
Od: dery®
Datum: 15.03.13 11:39

Díky, tohle je ale v pořádku, proto mi to nebylo jasný.
Všechno je tak, jak má být...
Ale prostě se to nezobrazuje :(

Datum: 15.03.13 11:55
avatar

Ppodívejte se do zdrojového kodu jestli máte správně napsané velká a malá písmena dokonce i velikost pismen v příponě souboru může dělat problémy.

Ohodnoceno: 2x
 
Od: 111®
Datum: 15.03.13 11:58

kdyby sem dal odkazna stránky jak, jsem psal, mohli jsme na zdroják kouknout...když nedá ať se trápí sám..

Ohodnoceno: 0x
 
Datum: 15.03.13 12:09
avatar

Souhlasím, bylo by to jednoduší tak akorát hádáme.

Ohodnoceno: 0x
 
Od: emergency
Datum: 15.03.13 12:00
..zkus zprůhlednit pozadí..vlož do EMBEDu wmode="transparent"
Ohodnoceno: 0x
 
Od: dery®
Datum: 15.03.13 12:31

Tak dlouho jsem si s tím teď hrála, až jsem to dodrbala asi úplně :-P
Už nevím, co bylo nastaveno v základu - u pozadí mám teď tohle.
Co nastavit, aby byl obrázek vidět?
Díky.

doplněno 15.03.13 12:31:

Obr.

Od: 111®
Datum: 15.03.13 12:37

a jak to máme vědět? nemáš náhodou v tom html souboru blbě zadaný obrázek i s celou cestou na C: disk?jak je vodět na tom obrázku co jsi vložila?

doplněno 15.03.13 12:38:

otevři zi html soubor v Notepadu

Ohodnoceno: 2x
 
Od: dery®
Datum: 15.03.13 12:47

Na webu se mi právě zobrazuje pouze barva, která je v tomhle nastavení zadaná (v tomto případě je tam bílá, viz první dvě políčka).
Cesta je správná.
Pokud na stránku mrknu v prohlížeči rovnou z programu, je to ok.
Ale pokud si pak otevřu prohlížeč/internet zvlášť, tak tam pozadí není.
Přitom "nahrané" je všechno správně.

Datum: 15.03.13 12:46
avatar

No možná bych ten background fakt nastavil na transparent ale takhle je to pořád dost těžko poradit. A jak říká kolega cesta k souboru je z c: ale je možná že to je jen cesta k souboru na disku nikoliv ve výsledném html souboru, těžko číct. Jinak co to je za editor wavemaker nebo něco podobného? Jo a možná by si to chtělo přečíst něco o základech HTML.

Ohodnoceno: 2x
 
Od: dery®
Datum: 15.03.13 12:48

Je to BlueVoda.

Nejsou to první stránky, co dělám, ale tenhle problém jsem ještě neměla.

Datum: 15.03.13 12:53
avatar

No napadlo mě a refreshujete? Myslím tím F5 nebo Shift+F5?

Ohodnoceno: 0x
 
Od: 111®
Datum: 15.03.13 12:54

hel zkus jednu věc. stiskni Ctrl+F5. možná si prohlížeč pamatuje stránku a čte to z paměti, a ty to potřebuješ znovu načíst z webu. takže Ctrl+F5

Ohodnoceno: 0x
 
Od: dery®
Datum: 15.03.13 12:58

Jo jo, refrešuju jak divá :( A nic.

Datum: 15.03.13 13:01
avatar

No bez odkazu či zdrojáku Vám možná asi nikdo nepomůže.

Ohodnoceno: 0x
 
Od: 111®
Datum: 15.03.13 13:05

sakra proč sem nedášodkaz na tránku, máš vůbec nějakou?

Ohodnoceno: 0x
 
Od: dery®
Datum: 15.03.13 13:18

Né, stránku nemám, proto to tady všechno asi řeším, že jo... *nevi*
Zrovna jsem vše chtěla dát do původního nastavení tak, jak jsem to měla, abych pak měla jasno, co a jak dělám špatně, a hodit sem odkaz a ejhle, ono to jede! Netuším jak...
Index valí, tak teď to zkusím na všechny ostatní podstránky a uvidíme.
Děkuji vám mockrát za ochotu ;)

Od: 111®
Datum: 15.03.13 13:20

že by závada mezi klávesnicí a židlí?*smich*

Ohodnoceno: 0x
 
Od: dery®
Datum: 15.03.13 13:33

No jo, ale kde konkrétně? *frajer*
Kdybych tak věděla, co jsem tam teď nastavila jinak, než tam bylo předtím, na úplném začátku... *bzum*

 

Od: 111®
Datum: 15.03.13 15:48

a ty si nezálohuješ soubory, když laboruješ? Já jo , třeba 10x stejný soubor a až je to OK tak pak vím co bylo špatně, nakonec to stejně smáznu, ale pokoukám co bylo jinak... tak snad příště.

Ohodnoceno: 0x
 
Datum: 15.03.13 20:37
avatar

Při psaní cesty k obrázku je třeba zadávat raději samá malá písmena a bez diakritiky. Nejhorší je záměna i za í - je to špatně vidět a už se mi to několikrát stalo. V PC to funguje a na serveru ne.

Ohodnoceno: 0x
 
Od: lego®
Datum: 15.03.13 20:46
avatar

Mas cestu k obrazku pozadi ve zdrojaku uvedenou na PC nebo na SERVER? Obrazek mas ulozenej na PC nebo na SERVERu?

Ohodnoceno: 0x
 
Datum: 15.03.13 23:27
avatar

Dejte mi sem odkaz na web, na kterém máte vše nahráno, podívám se na to.

Není-li v kořenovém adresáři soubor index.html, uveďte i název souboru, který tam máte místo něj.

Ohodnoceno: 0x
 

 

 

 

 

Přihlásit se k odběru odpovědí z této otázky:

Neneseme odpovědnost za správnost informací a za škodu vzniklou jejich využitím. Jednotlivé odpovědi vyjadřují názory jejich autorů a nemusí se shodovat s názorem provozovatele poradny Poradte.cz

 
Copyright © 2004-2016 Poradna Poradte.cz. Všechna práva na poradně Poradte.cz vyhrazena.