Excel fukce

Od: Datum: 31.01.13 17:33 odpovědí: 4 změna: 31.01.13 20:31

Dobrý den,

mam v excelu buňky s textem a potřeboval bych vytvořit nějakou funkci která projede tu buňku a najde nějaký dejmetomu písmeno. Když tam je tak vráti hodnotu 1 a když tam to písmeno není tak vrátí hodnotu 0.

např. mam buňku s textem "automobil" a vedle mam funkci která mi v ty buňce zjistí jestli tam je někde písmeno "i" když jo tak vrátí hodnotu 1 a když ne tak vrátí hodnotu 0.

zkoušel jsem funkci NAJIT ale tak když to písmeno nenajde tak nevráti hodnotu nula, ale vrátí chybu #HODNOTA! a stím pak nemužu dál pracovat

Nevěděl by někdo?

Předem dík



Seznam odpovědí:
 
moment čekejte prosím, probíhá přenos dat...
Zobrazení struktury odpovědí v otázce
Skrytí struktury odpovědí v otázce
Zobrazení struktury odpovědí v otázce

 

Odpovědi na otázku:
Datum: 31.01.13 18:52
avatar

Třeba takto: =SUMA(COUNTIF(A1;{"*A*"}))

Ohodnoceno: 2x
 
Od: karlos65
Datum: 31.01.13 20:29

Super díky funguje to skvěle.

Datum: 31.01.13 19:18
avatar

Stavající vzorec vložte do podmínky s funkcí JE.CHYBA(vaše vyhledání). Pokud ano, je chyba, napište si tam nulu; jinak napište nalezenou pozici.

=KDYŽ(JE.CHYBA(vyhledání);0;vyhledání)

Ohodnoceno: 2x
 
Od: karlos65
Datum: 31.01.13 20:31

funguje taky díky

 

 

Přihlásit se k odběru odpovědí z této otázky:

Neneseme odpovědnost za správnost informací a za škodu vzniklou jejich využitím. Jednotlivé odpovědi vyjadřují názory jejich autorů a nemusí se shodovat s názorem provozovatele poradny Poradte.cz

 
Copyright © 2004-2016 Poradna Poradte.cz. Všechna práva na poradně Poradte.cz vyhrazena.